Функция Excel Если значение ячейки равно одному из значений диапазона, то вставить значение из соседнего столбца

Excel Индекс Поискпоз Если ЛайфХаки

Как составить ms Excel / Эксель функции / формулу таблицы: Если значение ячейки равно одному из значений диапазона, то вставить значение из соседнего столбца или ячейки.

Примените функцию / формулу ИНДЕКС и ПОИСКПОЗ

=ИНДЕКС($P$2:$P$306;ПОИСКПОЗ(C2;$O$2:$O$306;0))

Расшифровка: функция ИНДЕКС (выделяем массив в котором ищем, т.е. список из которого будут браться значения и вставляться в ячейку куда мы эту формулу вписываем; далее ПОИСКПОЗИЦИИ (конкретное значение или ссылка на ячейку со значением которое ищем; далее массив список в котором ищем похожее значение; далее «»0″» — точное совпадение «»1″» — больше «»-1″» -меньше)». Мы ставим «0», чтобы нам подставилось то, что в найденной и сопоставленной ячейке будет.

Ставьте знак & (амперсант) перед буквой  столбца, и перед цифрой строки. Так выбор массива не будет съезжать вниз на строчку при копировании формулы на строчку ниже, т.е. амперсант сохраняет выбранное значение неизменным.

Microsoft office Excel лучшая электронная таблица, супер калькулятор

Формула Эксель Индекс и Поискпоз Таблица
Николай

Более 14 лет работаю юристом и имел дела с совершенно разными юридическими вопросами. На основании этого опыта и делюсь с вами полезностями

Оцените автора
В опыте | Vexperience.ru
Добавить комментарий